November 2009 Archives

IPv6 RA blocked in Fremont

| | Comments (1)
So last week at the he.net data center in Fremont, one of our providers switches rebooted and afterwards we haven't been receiving any IPv6 router advertisements on our lan. We contacted them immediately, but it still hasn't been fixed. Meanwhile, the workaround is to manually add a static default route and what the autoconfigured address would be if the RAs were being received. For example in linux, the command would be ip -6 route add default via 2001:470:1:41::1 dev eth0 for the default route and ip addr add 2001:470:1:41:(replace with host portion of your ipv6 address)/64 dev eth0.

maybe I"m just lazy and blind, but I can't find any post diagnostic cards that work with modern pci-express only servers

for those of you who are not janitors (or who work exclusively with tyan boards, which have an awesome post diagnostic LED on-board) a post diagnostic card reads I/O port 0080h, and prints out a 2 digit hex number on an LED display, which you can look up in the back of your motherboard manual to figure out what the hell is going on when your server is so goddamn loud you can't hear the goddamn beep codes. I had one that was PCI, and see many that are PCI and ISA, but I see none that would fit in my PCI-e only server. And I've got a supermicro that won't boot. One side of a 2 in 1u, too.

Example of a ISA/PCI post diagnostic card: http://www.elstonsystems.com/prod/pc_post_diagnostic_card.html

I need one of those, only I need it to plug into usb or serial or pci-express or some port my supermicro 2 in 1u servers have.

Meanwhile, I went ahead and overpaid for another stand-alone supermicro motherboard and hooked it into one of my old 3U chassis, so I should have capacity sometime later this week.

.